Ongoing Service Issue
Incident Report for GetResponse
Resolved
This incident has been resolved.
Posted Jan 11, 2024 - 07:20 EST
Identified
Our developers are working on solving the root cause of the issue. Thank you for your patience!
Posted Jan 11, 2024 - 04:38 EST
This incident affected: Webinars.