Ongoing Service Issue affecting EU and US Date Center Clients

Incident Report for GetResponse

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 16:50 CEST

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 15:13 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 20, 2025 - 11:08 CEST

Update

We're experiencing issues affecting some of our services. Our team is working on a solution. We will keep you updated on the progress.
Posted Oct 20, 2025 - 10:34 CEST

Investigating

We are currently investigating an issue that is causing recipient data to be missing from reports.
Posted Oct 19, 2025 - 08:55 CEST
This incident affected: Image Hosting, Reports, and Files and Images.