Message delivery delays
Incident Report for GetResponse
Resolved
We've cleared our sending queue. All your messages are now being delivered normally. Apologies for the disruption!
Posted Dec 06, 2021 - 04:55 EST
Investigating
Our sending queue is currently overloaded. Some users may be experiencing message delivery delays. We're working hard to resolve the issue as quickly as we can. Thanks for your patience!
Posted Dec 06, 2021 - 04:32 EST