Marketing Pages Issues

Incident Report for GetResponse

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 14:23 CEST

Update

We are continuing to investigate this issue.
Posted Apr 23, 2026 - 14:22 CEST

Investigating

We're experiencing issues with Marketing Pages.
Posted Apr 23, 2026 - 13:06 CEST
This incident affected: Marketing Pages.