Marketing Pages Issues

Incident Report for GetResponse

Resolved

This incident has been resolved.
Posted Nov 27, 2025 - 18:24 CET

Identified

We're experiencing issues affecting the GetResponse Help Center. Some users may see an error page when trying to use it. We're working on a fix as fast as we can and will keep you updated on the progress.
Posted Nov 27, 2025 - 13:54 CET
This incident affected: Marketing Pages.