Issues with our LiveChat
Incident Report for GetResponse
Resolved
This incident has been resolved.
Posted Sep 19, 2023 - 10:05 CEST
Investigating
We’re experiencing temporary server issues with our LiveChat provider. Chatting with Customer Success Team will be limited.
Posted Sep 19, 2023 - 09:57 CEST