Joining Webinars Issues

Incident Report for GetResponse

Resolved

We've resolved the issue affecting webinars. Apologies for the inconvenience!
Posted 4 years ago. Oct 13, 2021 - 11:17 CEST

Investigating

We're aware of delays and interruptions for attendees joining a webinar. We're working hard to fix the issue as soon as possible.
Posted 4 years ago. Oct 13, 2021 - 10:31 CEST