Ongoing Service Issue
Incident Report for GetResponse
Resolved
We're happy to report that we've resolved the issues affecting our system. There should be no more delays or interruptions. Thank you for sticking with us!
Posted Aug 14, 2024 - 10:25 CEST
Investigating
We're experiencing an issue with our services on EU and US Max Date Center. Our team is working on a solution and will keep you updated on the progress. Messages are going according to the planned schedule.
Posted Aug 14, 2024 - 10:24 CEST
This incident affected: Dasbhboard.