We're happy to report that we've resolved the issues affecting our system. There should be no more delays or interruptions. Thank you for sticking with us!
Posted 1 month ago. Mar 03, 2025 - 19:55 CET
Update
We are continuing to work on a fix for this issue.
Posted 1 month ago. Mar 03, 2025 - 15:53 CET
Update
We are continuing to work on a fix for this issue.
Posted 1 month ago. Mar 03, 2025 - 15:50 CET
Update
We are continuing to work on a fix for this issue.
Posted 1 month ago. Mar 03, 2025 - 15:49 CET
Identified
The issue has been identified and a fix is being implemented.
Posted 1 month ago. Mar 03, 2025 - 12:38 CET
Update
We are continuing to investigate this issue.
Posted 1 month ago. Mar 03, 2025 - 12:37 CET
Investigating
We're experiencing an issue with our services on EU Date Center Clients (Spain). Our team is working on a solution and will keep you updated on the progress.
Posted 1 month ago. Mar 03, 2025 - 12:32 CET
This incident affected: Forms and Popups, Files and Images, and Content creators.