Ongoing Service Issue with one of our services.
Incident Report for GetResponse
Resolved
We're happy to report that we've resolved the issues affecting our system. There should be no more delays or interruptions. Thank you for sticking with us!
Posted Dec 25, 2024 - 00:22 CET
Investigating
We're experiencing an issue with the performance of our services. Our team is working on a solution. We will keep you updated on the progress.
Posted Dec 24, 2024 - 22:31 CET
This incident affected: Dasbhboard and Website Builder.