Issues with log into GetResponse
Incident Report for GetResponse
Resolved
We've resolved the issue. Everyone should be able to log into GetResponse without any further disruptions. Thank you for your patience!
Posted Feb 28, 2023 - 07:17 EST
Investigating
Some users may be experiencing issues trying to log into GetResponse. Our team's working on a solution. We'll let you know when access to GetResponse is restored. Sorry for the disruption!
Posted Feb 28, 2023 - 07:10 EST