Possible downgraded performance resulting from network partner global issue

Incident Report for GetResponse

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 10:28 CET

Investigating

We are investigating the impact of network partner issue upon GetResponse accessibility.
Posted Dec 05, 2025 - 10:03 CET