Ongoing Service Issue
Incident Report for GetResponse
Resolved
This incident has been resolved.
Posted Dec 06, 2023 - 13:23 CET
Investigating
We're experiencing an issue with one of our services. Our team is working on a solution. We will keep you updated on the progress.
Posted Dec 06, 2023 - 12:56 CET
This incident affected: Contacts (+Import).