Ongoing Service Issue affecting EU and US Self-Service Clients

Incident Report for GetResponse

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 16:25 CET

Investigating

Message sends are being delayed. We are investigating the issue.
Posted Oct 28, 2025 - 15:54 CET
This incident affected: Email Delivery.