Ongoing Service Issue
Incident Report for GetResponse
Resolved
We're happy to report that we've resolved the issues affecting our system. There should be no more delays or interruptions. Thank you for sticking with us!
Posted Dec 24, 2023 - 03:35 EST
Investigating
We're experiencing an issue with one of our services. Our team is working on a solution. We will keep you updated on the progress. We are experiencing issues with EU MAX clients. It does not concern SMB and US MAX.
Posted Dec 24, 2023 - 03:28 EST
This incident affected: Dasbhboard.